nsForum logo

Welcome Guest ( Log In )

 
Reply to this topicStart new topic
> Can't Connect Ftp
rrcc
post Aug 24 2014, 01:57 AM
Post #1





Group: Verified NS Member
Posts: 4
Joined: 24-August 14
Member No.: 23,147



i can't connect ftp of the VPS from China, always get error.
i tried cuteftp, filezella, leapftp. i can use these software to connect any other websites of other ISPs in different countries. just can't connect yours.
i have to cancel the hosting plan and ssl if can't upload files.
i already tried to contact you 3 days, nobody answer me. I'm really tired.

1, if use port 21, error:
STATUS:> [2014/8/24 15:04:58] Connecting to FTP server... ftp.toperfect.com:21 (ip = 69.161.222.130)...
ERROR:> [2014/8/24 15:05:19] The connection failed due to an error or timeout.

2, port 22, error:
STATUS:> [2014/8/24 15:06:05] Connecting to FTP server... ftp.toperfect.com:22 (ip = 69.161.222.130)...
STATUS:> [2014/8/24 15:06:06] Socket connected. Waiting for welcome message...
ERROR:> [2014/8/24 15:07:06] Timeout (60000 ms) occurred on receiving server response.
Go to the top of the page
 
+Quote Post
Craig
post Aug 24 2014, 07:59 PM
Post #2





Group: Administrators
Posts: 988
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (rrcc @ Aug 24 2014, 02:57 AM) *
i can't connect ftp of the VPS from China, always get error.
i tried cuteftp, filezella, leapftp. i can use these software to connect any other websites of other ISPs in different countries. just can't connect yours.
i have to cancel the hosting plan and ssl if can't upload files.
i already tried to contact you 3 days, nobody answer me. I'm really tired.

1, if use port 21, error:
STATUS:> [2014/8/24 15:04:58] Connecting to FTP server... ftp.toperfect.com:21 (ip = 69.161.222.130)...
ERROR:> [2014/8/24 15:05:19] The connection failed due to an error or timeout.

2, port 22, error:
STATUS:> [2014/8/24 15:06:05] Connecting to FTP server... ftp.toperfect.com:22 (ip = 69.161.222.130)...
STATUS:> [2014/8/24 15:06:06] Socket connected. Waiting for welcome message...
ERROR:> [2014/8/24 15:07:06] Timeout (60000 ms) occurred on receiving server response.

Make sure you are not using passive mode, as passive mode is not supported by the default VPS firewall configuration. If you need or want to use passive mode, you have to enable the setting for it in the firewall in Virtuozzo.
Go to the top of the page
 
+Quote Post
rrcc
post Aug 24 2014, 08:24 PM
Post #3





Group: Verified NS Member
Posts: 4
Joined: 24-August 14
Member No.: 23,147



QUOTE (Craig @ Aug 24 2014, 08:59 PM) *
Make sure you are not using passive mode, as passive mode is not supported by the default VPS firewall configuration. If you need or want to use passive mode, you have to enable the setting for it in the firewall in Virtuozzo.

i already tried different connection types of golobal settings, port, pasv,eprt,epsv; and firewall is
Access to outer world Allow all outgoing connections
DNS server Access to DNS server
Internal Services Access to Virtual Environment Services from inside Virtual Environment
Mail server Access to Mail server
Plesk server Access to Plesk Control Panel
POP3 server Access to POP3 server
SSH server Access to SSH server
WEB server Access to WEB server

nothing work!
Go to the top of the page
 
+Quote Post
Craig
post Aug 25 2014, 04:17 AM
Post #4





Group: Administrators
Posts: 988
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (rrcc @ Aug 24 2014, 09:24 PM) *
i already tried different connection types of golobal settings, port, pasv,eprt,epsv; and firewall is
Access to outer world Allow all outgoing connections
DNS server Access to DNS server
Internal Services Access to Virtual Environment Services from inside Virtual Environment
Mail server Access to Mail server
Plesk server Access to Plesk Control Panel
POP3 server Access to POP3 server
SSH server Access to SSH server
WEB server Access to WEB server

nothing work!

You need to add the rule for FTP. Also, you can try using SFTP (FTP over SSH).
Go to the top of the page
 
+Quote Post
rrcc
post Aug 25 2014, 04:25 AM
Post #5





Group: Verified NS Member
Posts: 4
Joined: 24-August 14
Member No.: 23,147



QUOTE (Craig @ Aug 25 2014, 05:17 AM) *
You need to add the rule for FTP. Also, you can try using SFTP (FTP over SSH).

i find out that i can only log in ftp with root account.
Go to the top of the page
 
+Quote Post
Craig
post Aug 25 2014, 04:56 AM
Post #6





Group: Administrators
Posts: 988
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (rrcc @ Aug 25 2014, 05:25 AM) *
i find out that i can only log in ftp with root account.

SFTP is only root, unless you do some manual configuration.
Go to the top of the page
 
+Quote Post
GarthHenning
post Sep 22 2014, 10:36 PM
Post #7





Group: Verified NS Member
Posts: 12
Joined: 28-February 09
From: Washington, DC
Member No.: 3,872




Craig,

I was having this same problem. Per your suggestion above, switching to SFTP solved it. And was probably a good idea anyway.

With thanks,
-Garth
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
Tags
No Tag inserted yet

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

RSS Lo-Fi Version    Network Solutions © 2011 Time is now: 19th October 2017 - 04:17 PM
Domain Names | Web Hosting | Web Design | Shopping Cart Software | Online Marketing | SSL Certificates