nsForum logo

Welcome Guest ( Log In )

Reply to this topicStart new topic
> Problem Changing Wordpress Url (netsolhost Address Appearing)
post Jun 30 2011, 03:30 AM
Post #1

Group: Verified NS Member
Posts: 4
Joined: 29-June 11
Member No.: 14,588

I've done a fair amount of searching for help online with this and have unfortunately drawn a blank with online support requests (3 so far) and phone help (40 minutes and 25 minutes from the UK), but apologies if I'm missing something obvious.

We installed a WordPress site on NS and have the WordPress Hosting package with NS (this is the one that doesn't come with FTP access).

We have assigned our domain to the hosting package.

Relevant domains are here:


We have the often cited (but in our case at least - unsolved) problem that once a user visits a page beyond the homepage (http://friendsofavenuehouse.org) the address bar URL reverts to 3030ababnetsolhost.com.

This is the point at which many people will say read this article:


So, we read the article, and the WordPress codex article that's referred to within it:


So, following the WordPress codex article (which is the first step) we attempt to change the Home and Site URLs in the Settings -> General screen.

But then the site breaks and we have to go and edit the WordPress database to regain access to the Admin panel so we can change the values back again.

So, maybe the URL is wrong or the domain is not pointing to the right place, so we carry on with the NS article.

It says:

2. Click on My Hosting Package

But there is no option which says My Hosting Package (because we don't have full NS Hosting just WordPress Hosting). We can only click on My Blog Package instead and see if we can follow the next instructions, which say:

3. If you have one hosting package, go directly to Step 4. If you have more than one hosting package, click on the Hosting package for which you want to un-assign a domain name.
4. Under the Web Hosting Details scroll to the Domain Names Pointing to this Package section.
5. Find the domain name you wish to change the directory for the right of the domain click Edit.
6. Use the drop down to the right of the domain to point to your WordPress® directory or Add directory not listed and click Select.

But unfortunately there is no option to edit the Manage Domains section (which is the closest looking section to the instructions provided. We just have:

Web Address Options
http://033abab.netsolhost.com default
http://friendsofavenuehouse.org (View DNS) Remove
http://www.friendsofavenuehouse.org Remove

So we can't do anything with this section of the instructions and hit a dead end - although the NS tech guy I spoke to yesterday said, it's configured correctly so it doesn't matter that the instruction are wrong because it's a problem with the way WordPress is configured and I can pay $99 if I want NS to solve it for me within 48 business hours (which I think is 6 working days?).


So, if it's a problem with the WordPress configuration I'm thinking maybe the URL's are wrong once changed - and that's why the site breaks. Going back to the WordPress article (http://codex.wordpress.org/Changing_The_Site_URL) I see that it's possible to get WordPress to "figure out and update those values for you automatically."

This sounds great. Just need to add:


into the wp-config.php

But, the problem is I can't access that file without FTP access.

And that's where I get stuck.

Sorry for the long post, I hope I've been sufficiently diligent in trying to solve the problem myself from the information that's out there on the internet and I'd really appreciate anyone's help in resolving this.
Go to the top of the page
+Quote Post
post Jul 7 2011, 10:29 AM
Post #2

Group: Verified NS Member
Posts: 4
Joined: 29-June 11
Member No.: 14,588

Ok, humble pie time - for the greater good.

I had simply changed the HOME URL and SITE URLs from:




And, in my panic unchanged them when the site broke.

Also, without FTP, there was no way of getting into the site backend to see where WordPress is actually stored.

After plucking up the courage to risk breaking the site again, I tried changing the HOME URL and SITE URLs to just:


and...it worked.

I've subsequently had to go through most of the pages and update the links which were hard coded into the pages (although I'm sure I could have done this through a database edit if I had been brave enough).

I can see that I could have fixed this more quickly myself if I'd been happy to experiment further.

However, I am also a little surprised that Network Solutions weren't more more helpful - "just make sure you just quote the domain and don't leave the '/Wordpress' bit in" would have done the trick for me!
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
No Tag inserted yet

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version    Network Solutions © 2011 Time is now: 16th December 2017 - 05:13 PM
Domain Names | Web Hosting | Web Design | Shopping Cart Software | Online Marketing | SSL Certificates