nsForum logo

Welcome Guest ( Log In )

 
Reply to this topicStart new topic
> Cannot Send Email From Joomla 3, Cannot send email from Joomla 3
JNKody
post May 29 2013, 07:35 PM
Post #1





Group: Verified NS Member
Posts: 4
Joined: 18-May 13
Member No.: 20,798



I am unable to send email from Joomla. This includes user registration confirmations, contact forms, etc.

Here is my setup ...

  • Network Solutions: Essential Hosting (Linux)
  • Joomla 3.0
  • Email is hosted elsewhere; hosted Exchange solution (not NS)
  • The site was developed on a local LAMP box and migrated to the NS hosting account.


I should note at this point I have used this same procedure dozens of times (more than 50) without fail. This is the first time my client is hosted with NS, so I am inclined to believe the issue is with NS and not something I am doing wrong.

NS "tech support" (and I use the term very loosely) says the problem is with "the script I am using" and offered to escalate the issue to 2nd level. Of course, this escalation comes with a fee. "The script I am using" is working on about a brazillian other web sites all over the world, so again, I am inclined to believe the problem is with NS. My client is not willing to pay for 2nd level support and nor do I believe they should have to.

Things I have tried:

PHPMail, Sendmail, SMTP, SMTP w/ SSL, with every possible configuration option.

I also tried to use a GMail account with SMTP auth. I actually got the email an email to go out 1 time ... and Google proceeded to lock out my account due to an "unauthorized remote login".

Any advice / assistance on this issue would be appreciated.

Without a solution here, I am going to advise my client to find a different host.
Go to the top of the page
 
+Quote Post
Craig
post May 29 2013, 07:47 PM
Post #2





Group: Administrators
Posts: 990
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (JNKody @ May 29 2013, 08:35 PM) *
I am unable to send email from Joomla. This includes user registration confirmations, contact forms, etc.

Here is my setup ...

  • Network Solutions: Essential Hosting (Linux)
  • Joomla 3.0
  • Email is hosted elsewhere; hosted Exchange solution (not NS)
  • The site was developed on a local LAMP box and migrated to the NS hosting account.


I should note at this point I have used this same procedure dozens of times (more than 50) without fail. This is the first time my client is hosted with NS, so I am inclined to believe the issue is with NS and not something I am doing wrong.

NS "tech support" (and I use the term very loosely) says the problem is with "the script I am using" and offered to escalate the issue to 2nd level. Of course, this escalation comes with a fee. "The script I am using" is working on about a brazillian other web sites all over the world, so again, I am inclined to believe the problem is with NS. My client is not willing to pay for 2nd level support and nor do I believe they should have to.

Things I have tried:

PHPMail, Sendmail, SMTP, SMTP w/ SSL, with every possible configuration option.

I also tried to use a GMail account with SMTP auth. I actually got the email an email to go out 1 time ... and Google proceeded to lock out my account due to an "unauthorized remote login".

Any advice / assistance on this issue would be appreciated.

Without a solution here, I am going to advise my client to find a different host.

You cannot connect to an external SMPT server. PHPMail or Sendmail should work as long as you don't change the SMTP server setting. If you are going to use SMTP, the only thing that will work is to use "localhost" as the SMTP server with no login.
Go to the top of the page
 
+Quote Post
JNKody
post May 29 2013, 08:00 PM
Post #3





Group: Verified NS Member
Posts: 4
Joined: 18-May 13
Member No.: 20,798



Yes, I agree PHPMail or Sendmail should work, and yet, here I am, posting in a Forum because it is not working.
Go to the top of the page
 
+Quote Post
JNKody
post May 29 2013, 08:11 PM
Post #4





Group: Verified NS Member
Posts: 4
Joined: 18-May 13
Member No.: 20,798



Here is the error message I get when I submit the Contact form. The email is never sent/received.

==========
Notice
SMTP Error! Data not accepted.
SMTP server error: 2.1.5 ... Recipient ok
==========
Go to the top of the page
 
+Quote Post
Craig
post May 29 2013, 09:40 PM
Post #5





Group: Administrators
Posts: 990
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (JNKody @ May 29 2013, 09:11 PM) *
Here is the error message I get when I submit the Contact form. The email is never sent/received.

==========
Notice
SMTP Error! Data not accepted.
SMTP server error: 2.1.5 ... Recipient ok
==========

I tested using a script which uses the PHP mail() function and the PHP PEAR moduel to send a message, and it worked. I will send you the URL of the script via private message.
Go to the top of the page
 
+Quote Post
JNKody
post May 30 2013, 08:29 PM
Post #6





Group: Verified NS Member
Posts: 4
Joined: 18-May 13
Member No.: 20,798



I have mixed results with the test script. The first test was successful, but subsequent tests failed -- similar to what happened when sending from Joomla a few nights ago. I got one (1) test email but subsequent tests -- without changing anything in the config -- failed.

Yes, I checked my Junk folder.

I have an identical Joomla setup for a number of other clients and I just tested 8 different sites on various web hosts. Hosts tested include Siteground, Lunarpages, JustHost, HostGator and InMotion and the email is sent/received successfully. Tests from Network Solutions hosting, however, are never received.

There is no indication in the logs that the emails allegedly sent from NS ever reached their destination, but I can clearly see the email transaction from the other hosts. As I told Tech Support repeatedly, THIS IS NOT A JOOMLA PROBLEM; THIS IS NOT A SCRIPT PROBLEM; THIS IS A NETWORK SOLUTIONS PROBLEM!

<shouting intentional>
Go to the top of the page
 
+Quote Post
Craig
post Jun 2 2013, 09:24 PM
Post #7





Group: Administrators
Posts: 990
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (JNKody @ May 30 2013, 09:29 PM) *
I have mixed results with the test script. The first test was successful, but subsequent tests failed -- similar to what happened when sending from Joomla a few nights ago. I got one (1) test email but subsequent tests -- without changing anything in the config -- failed.

Yes, I checked my Junk folder.

I have an identical Joomla setup for a number of other clients and I just tested 8 different sites on various web hosts. Hosts tested include Siteground, Lunarpages, JustHost, HostGator and InMotion and the email is sent/received successfully. Tests from Network Solutions hosting, however, are never received.

There is no indication in the logs that the emails allegedly sent from NS ever reached their destination, but I can clearly see the email transaction from the other hosts. As I told Tech Support repeatedly, THIS IS NOT A JOOMLA PROBLEM; THIS IS NOT A SCRIPT PROBLEM; THIS IS A NETWORK SOLUTIONS PROBLEM!

<shouting intentional>

I was able to use the test script to send to both Gmail and our corporate exchange server without issue.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
Tags
No Tag inserted yet

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

RSS Lo-Fi Version    Network Solutions © 2011 Time is now: 22nd November 2017 - 11:25 AM
Domain Names | Web Hosting | Web Design | Shopping Cart Software | Online Marketing | SSL Certificates