nsForum logo

Welcome Guest ( Log In )

 
Reply to this topicStart new topic
> Can't Access Gallery After Install
moonrise
post May 9 2012, 02:23 PM
Post #1





Group: Verified NS Member
Posts: 3
Joined: 9-May 12
Member No.: 17,454



Anybody have any experience with the Gallery application?

Installed it from the list of Open Source apps. That seemed to go fine, it shows up in My Installed Apps with status Installed. But when I try to access it, either by the link shown as its address (http://[hexdigits].netsolhost.com/gallery1) or the "gallery1 Login Page" link, I get "500: Internal Server Error".

Any help or hints appreciated.
Go to the top of the page
 
+Quote Post
Craig
post May 9 2012, 10:05 PM
Post #2





Group: Administrators
Posts: 988
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (moonrise @ May 9 2012, 03:23 PM) *
Anybody have any experience with the Gallery application?

Installed it from the list of Open Source apps. That seemed to go fine, it shows up in My Installed Apps with status Installed. But when I try to access it, either by the link shown as its address (http://[hexdigits].netsolhost.com/gallery1) or the "gallery1 Login Page" link, I get "500: Internal Server Error".

Any help or hints appreciated.

The version of Gallery that is available in the Open Source Library is not compatible with the version of PHP we are using now. I do not know when this will be updated.

The issue with the version that is installed is that it tries to use functions from ZendOptimizer. ZendOptimizer support ends with PHP 5.2.x. You can fix it by putting the following settings in your php.ini file:
CODE
zend_loader.enable = 0
zend_loader.obfuscation_level_support = 0


Instructions for modifying php.ini settings can be found at http://www.networksolutions.com/support/PH...ed-Hosting-FAQ/
Go to the top of the page
 
+Quote Post
moonrise
post May 12 2012, 09:46 AM
Post #3





Group: Verified NS Member
Posts: 3
Joined: 9-May 12
Member No.: 17,454



Hi Craig,

Thanks for the reply. I created a php.ini in /cgi-bin containing those two lines, and removed and reinstalled Gallery. Now I get: "Fatal error: Cannot run code from this file in conjunction with encoded files in Unknown on line 0". What else am I missing?

edit...
Had forgotten to delete /cgi-bin/.php/php.ini.coalesced, but doing that didn't change anything. Created a phpinfo.php in /htdocs, that gets the same "Fatal error...".
Go to the top of the page
 
+Quote Post
Korey N
post May 13 2012, 01:51 AM
Post #4





Group: NetSol Staff
Posts: 150
Joined: 15-March 12
From: PA
Member No.: 16,875



QUOTE (moonrise @ May 12 2012, 10:46 AM) *
Hi Craig,

Thanks for the reply. I created a php.ini in /cgi-bin containing those two lines, and removed and reinstalled Gallery. Now I get: "Fatal error: Cannot run code from this file in conjunction with encoded files in Unknown on line 0". What else am I missing?

edit...
Had forgotten to delete /cgi-bin/.php/php.ini.coalesced, but doing that didn't change anything. Created a phpinfo.php in /htdocs, that gets the same "Fatal error...".


Looks like the coalesced file regenerated so it is overriding your changes. This happens sometimes if you do not do this in the right order and causes your php.ini not to be picked up by the server.
Go to the top of the page
 
+Quote Post
moonrise
post May 13 2012, 07:53 AM
Post #5





Group: Verified NS Member
Posts: 3
Joined: 9-May 12
Member No.: 17,454



Makes sense. But at this point, the coalesced file doesn't exist. I modified a comment in php.ini to change its dates. Still the "Fatal error...". Is there something I can do to induce the server to see the change? Thanks.
Go to the top of the page
 
+Quote Post
Craig
post May 13 2012, 08:25 PM
Post #6





Group: Administrators
Posts: 988
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (moonrise @ May 13 2012, 08:53 AM) *
Makes sense. But at this point, the coalesced file doesn't exist. I modified a comment in php.ini to change its dates. Still the "Fatal error...". Is there something I can do to induce the server to see the change? Thanks.

That fix seems to work for most Gallery installations, but it may not work for the particular version you are using. You may need to try doing a manual install of the latest version of Gallery to see if that is more compatible with PHP 5.3. You can dowload the current version at http://codex.gallery2.org/Downloads.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
Tags
No Tag inserted yet

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

RSS Lo-Fi Version    Network Solutions © 2011 Time is now: 19th August 2017 - 01:17 PM
Domain Names | Web Hosting | Web Design | Shopping Cart Software | Online Marketing | SSL Certificates