nsForum logo

Welcome Guest ( Log In )

 
Reply to this topicStart new topic
> Fatal Error Message For Wordpress, Fatal error: Allowed memory size of 33554432 bytes exhausted...
mjf966
post Feb 10 2012, 07:27 AM
Post #1





Group: Verified NS Member
Posts: 1
Joined: 10-February 12
Member No.: 16,526



Dear members,

I have just purchase with Network Solutions their WordPress package, but, after few initial setting at my database, any further attempt to access to the dashboard or any other administration tool gives me this uncomfortable message:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /data/26/2/38/80/2690080/user/2954411/htdocs/WordPress/wp-admin/includes/template.php on line 1311

Even if I found online the literature where other users explain where to go inside the database and solve the issue, it seems Network Solutions doesn't allow us to access to WordPress database settings.

Any of you has experienced the same problem? How to solve it?

Thank you for any help!

mjf
Go to the top of the page
 
+Quote Post
Craig
post Feb 12 2012, 07:46 PM
Post #2





Group: Administrators
Posts: 988
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (mjf966 @ Feb 10 2012, 07:27 AM) *
Dear members,

I have just purchase with Network Solutions their WordPress package, but, after few initial setting at my database, any further attempt to access to the dashboard or any other administration tool gives me this uncomfortable message:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /data/26/2/38/80/2690080/user/2954411/htdocs/WordPress/wp-admin/includes/template.php on line 1311

Even if I found online the literature where other users explain where to go inside the database and solve the issue, it seems Network Solutions doesn't allow us to access to WordPress database settings.

Any of you has experienced the same problem? How to solve it?

Thank you for any help!

mjf

Something in your template is trying to use more memory than is allocated by PHP. You either need to switch to a different template or increase the memory limit.

You need FTP access to create a /cgi-bin/php.ini to increase the memory limit. You can either upgrade to nsHosting Unix and do it yourself, or have our MyTime paid support team do it for you ($59.99 charge). You can do the upgrade through your Account Manager by clicking on the upgrade link on the page where you manage your WordPress Hosting. If you wish to set up MyTime support, you will need to call our Support Center.
Go to the top of the page
 
+Quote Post
hulbert
post Feb 17 2012, 08:27 PM
Post #3





Group: Verified NS Member
Posts: 1
Joined: 17-February 12
Member No.: 16,604



amazing because i'm having the same problems with my Joomla site and I MEAN THE EXACT ERROR MESSAGE and i did go into the cgi bin and increase the size of the php.ini file from 32M to 64M and it makes no difference at all - network solutions needs to solve this problem because i know other hosts that have NO PROBLEM with templates of any size

steve h
Go to the top of the page
 
+Quote Post
Craig
post Feb 19 2012, 09:19 PM
Post #4





Group: Administrators
Posts: 988
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (hulbert @ Feb 17 2012, 08:27 PM) *
amazing because i'm having the same problems with my Joomla site and I MEAN THE EXACT ERROR MESSAGE and i did go into the cgi bin and increase the size of the php.ini file from 32M to 64M and it makes no difference at all - network solutions needs to solve this problem because i know other hosts that have NO PROBLEM with templates of any size

steve h

I checked your hosting package, and there is no /cgi-bin/php.ini file. If you made the changes directly in the /cgi-bin/.php/php.coalesced.ini files, those changes could be overwritten. Instructions for making changes to php.ini settings can be found at http://www.networksolutions.com/support/PH...ed-Hosting-FAQ/.
Go to the top of the page
 
+Quote Post
Bedazzled
post Mar 28 2012, 01:56 PM
Post #5





Group: Verified NS Member
Posts: 1
Joined: 28-March 12
Member No.: 17,027



So...answer me this. Exactly how are we supposed to change the template (if that's the cause...my error message came after I think I got a little too widget-happy) if we can't even login? I purchased this package because it was supposed to be easy and wouldn't require much technical know-how on my end. Seems somewhat scammy to now suggest we need to upgrade or basically pay someone the equivalent to fix.
Go to the top of the page
 
+Quote Post
Korey N
post Mar 29 2012, 06:36 AM
Post #6





Group: NetSol Staff
Posts: 150
Joined: 15-March 12
From: PA
Member No.: 16,875



Bedazzled,

You purchased a package at a cheaper price. The reason the package is cheaper is because of its limitations compared to our regular nsHosting Shared package which has more access like FTP access. That is why you would need to upgrade to make the change. If you do not wish to do that we offer the service you mentioned called MyTime support where we can have a skilled technician go into the back-end and make these changes for you.

If you need to change the template you may be able to do that via PHPMyAdmin (database manager). This would take some knowledge so before making changes you would want to either have your developer do this or research instructions online.
Go to the top of the page
 
+Quote Post
YourITguy
post Aug 16 2012, 01:04 AM
Post #7





Group: Verified NS Member
Posts: 1
Joined: 16-August 12
Member No.: 18,268



OK, so I am on the nsHosting package and my Wordpress blog is down due to the same issue! Let's see if you can fix my issue as I am paying for the nsHosting package you say that this would fix, not the "cheaper" package you say this poor guy here has..
My site displays this same Memory issue when viewing it and I had Network Solutions install my Wordpress blog. I have added 1 theme and 1 plugin and already I get the Memory issue!


First I got this below Memory issue on my home page http://[domain remvoed].net/home/ :
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 64 bytes) in /data/15/1/157/6/xxxxxxx/user/xxxxxxx/htdocs/home/wp-includes/widgets.php on line 803


Then, I tried the "fix" you show on this forum: http://www.networksolutions.com/support/PH...ed-Hosting-FAQ/

Which then gave me not only the above memory issue, but also this below issue, and I followed the article exactly as stated to add the memory increase settings to 64mb.

I then got this error, plus the above error:

500: Internal server error
This error is generated when a script running on the server could not be implemented or permissions are incorrectly assigned for files or directories
Troubleshooting suggestions:
Temporarily disable any rewrite rules by renaming your .htaccess file if it exists.
Ensure that any CGI or Perl scripts have at least .755. permissions.
If trying to run PHP and you get this error, you may have an invalid php.ini in your /cgi-bin, or may be missing your php.dat file in this folder.


I opened up an internal Case and was told that you will not support editing the PHP file!! Then, what are we supposed to do?

After being more frustrated, I was "suggested" by a Chat support and was told to only have the settings in the article in the php.ini file, but to also delete all the other lines in the php.ini.

Then, I got this Error!!

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.


This is the worst experience I have ever had with a hosting Provider, and honestly I have never had any issues with these same exact Wordpress version, template, and plugin and they would support me with no issue even it ever did happen!
Please help or I will be switching over the rest of my sites to GoDaddy as one already has!
Go to the top of the page
 
+Quote Post
Craig
post Aug 16 2012, 02:24 AM
Post #8





Group: Administrators
Posts: 988
Joined: 23-June 08
From: Pennsylvania
Member No.: 1,317



QUOTE (YourITguy @ Aug 16 2012, 02:04 AM) *
OK, so I am on the nsHosting package and my Wordpress blog is down due to the same issue! Let's see if you can fix my issue as I am paying for the nsHosting package you say that this would fix, not the "cheaper" package you say this poor guy here has..
My site displays this same Memory issue when viewing it and I had Network Solutions install my Wordpress blog. I have added 1 theme and 1 plugin and already I get the Memory issue!


First I got this below Memory issue on my home page http://[domain remvoed].net/home/ :
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 64 bytes) in /data/15/1/157/6/xxxxxxx/user/xxxxxxx/htdocs/home/wp-includes/widgets.php on line 803


Then, I tried the "fix" you show on this forum: http://www.networksolutions.com/support/PH...ed-Hosting-FAQ/

Which then gave me not only the above memory issue, but also this below issue, and I followed the article exactly as stated to add the memory increase settings to 64mb.

I then got this error, plus the above error:

500: Internal server error
This error is generated when a script running on the server could not be implemented or permissions are incorrectly assigned for files or directories
Troubleshooting suggestions:
Temporarily disable any rewrite rules by renaming your .htaccess file if it exists.
Ensure that any CGI or Perl scripts have at least .755. permissions.
If trying to run PHP and you get this error, you may have an invalid php.ini in your /cgi-bin, or may be missing your php.dat file in this folder.


I opened up an internal Case and was told that you will not support editing the PHP file!! Then, what are we supposed to do?

After being more frustrated, I was "suggested" by a Chat support and was told to only have the settings in the article in the php.ini file, but to also delete all the other lines in the php.ini.

Then, I got this Error!!

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.


This is the worst experience I have ever had with a hosting Provider, and honestly I have never had any issues with these same exact Wordpress version, template, and plugin and they would support me with no issue even it ever did happen!
Please help or I will be switching over the rest of my sites to GoDaddy as one already has!


When I just checked your site, I was not getting the error. Also, when I checked the output of phpinfo() it is showing 128 MB as you set in your /cgi-bin/php.ini.
Go to the top of the page
 
+Quote Post
Glenmore
post Aug 27 2012, 08:42 AM
Post #9





Group: Verified NS Member
Posts: 3
Joined: 27-August 12
Member No.: 18,342



QUOTE (Craig @ Aug 16 2012, 03:24 AM) *
When I just checked your site, I was not getting the error. Also, when I checked the output of phpinfo() it is showing 128 MB as you set in your /cgi-bin/php.ini.


I am having a similar problem (Wordpress) and have followed the above steps. When I run the phpinfo(INFO_ALL); command I see that I have 128M allocated, but I am still getting an error " Allowed memory size of 33554432 bytes exhausted"

I notice in my rebuilt php.coalesced.ini that "memory_limit = 128M" so it is picking up that.

I have also manually set the memory definition in Wordpress in both the wp-settings.php and wp-config.php. Anything else I can try?

Go to the top of the page
 
+Quote Post
Korey N
post Aug 29 2012, 09:20 PM
Post #10





Group: NetSol Staff
Posts: 150
Joined: 15-March 12
From: PA
Member No.: 16,875



QUOTE (Glenmore @ Aug 27 2012, 09:42 AM) *
I am having a similar problem (Wordpress) and have followed the above steps. When I run the phpinfo(INFO_ALL); command I see that I have 128M allocated, but I am still getting an error " Allowed memory size of 33554432 bytes exhausted"

I notice in my rebuilt php.coalesced.ini that "memory_limit = 128M" so it is picking up that.

I have also manually set the memory definition in Wordpress in both the wp-settings.php and wp-config.php. Anything else I can try?


There is a specific way/order to doing this fix as the server itself has a default and overwrites the coalesced.ini

Here is our FAQ help document. I would do as this recommends, perhaps the way you are doing it is not actually overwriting as it should.

http://www.networksolutions.com/support/PH...ed-Hosting-FAQ/
Go to the top of the page
 
+Quote Post
Glenmore
post Sep 6 2012, 12:17 PM
Post #11





Group: Verified NS Member
Posts: 3
Joined: 27-August 12
Member No.: 18,342



QUOTE (Korey N @ Aug 29 2012, 10:20 PM) *
There is a specific way/order to doing this fix as the server itself has a default and overwrites the coalesced.ini

Here is our FAQ help document. I would do as this recommends, perhaps the way you are doing it is not actually overwriting as it should.

http://www.networksolutions.com/support/PH...ed-Hosting-FAQ/


Have tried it and it is apparently picking up the setting in PHP, but it isn't affecting Wordpress:
http://0362a98.netsolhost.com/frontiertech/phptest.php

In Wordpress I am using a plugin called WP-Memory-Usage that shows me Wordpress only thinks I have 32M to work with. I have tried resetting this value in the config file, but it still isn't changing the value. Anything else to try?
Go to the top of the page
 
+Quote Post
Glenmore
post Sep 6 2012, 12:33 PM
Post #12





Group: Verified NS Member
Posts: 3
Joined: 27-August 12
Member No.: 18,342



QUOTE (Glenmore @ Sep 6 2012, 01:17 PM) *
Have tried it and it is apparently picking up the setting in PHP, but it isn't affecting Wordpress:
http://0362a98.netsolhost.com/frontiertech/phptest.php

In Wordpress I am using a plugin called WP-Memory-Usage that shows me Wordpress only thinks I have 32M to work with. I have tried resetting this value in the config file, but it still isn't changing the value. Anything else to try?


Disregard: I found the hard-coded settings in "wp-includes/cache.php" and "wp-includes/default-constants.php"
Search for "32M" and replace with "64M"
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
Tags
No Tag inserted yet

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

RSS Lo-Fi Version    Network Solutions © 2011 Time is now: 17th August 2017 - 10:14 AM
Domain Names | Web Hosting | Web Design | Shopping Cart Software | Online Marketing | SSL Certificates