nsForum logo

Welcome Guest ( Log In )

 
Reply to this topicStart new topic
> How To Send Email With Perl On Network Solutions Servers
renolds
post Apr 16 2012, 04:54 PM
Post #1





Group: Verified NS Member
Posts: 1
Joined: 16-April 12
Member No.: 17,243



I cannot seem to send an email via a perl script on Network Solutions servers.

According to this:
http://www.networksolutions.com/support/wh...osting-package/

I am supposed to have the "Mail::Sendmail" module, but that does not work. Googling around the Internet a bit gives me the impression that it did work at one time. But it no longer does.

In fact, I have tried multiple approaches to sending an email via a perl script, and basically, nothing works.

I finally have the grotesque 3312 line long FormMail.pl script generated by the "make a form" tool available in the Site Manager. I am trying to hack this apart and isolate just the bit that sends an email. So that eventually I would have a function like so...

SendNSMail( $to, $from, $subject, $message );

Or something like that. I almost have it, but not without leaving most of the 3000 lines or so. Having to include 3000 lines or so in every script I write is just awful - it looks hideous and makes the script a pain to write and maintain.

So I've tried making my hacked up FormMail.pl with the SendNSMail function a perl module, but that won't work. It works on my test machine, but I can't seem to get my script to use the module on Network Solutions servers in any way. I also tried just using a simple "require 'MyHackedFormMail.pl'; " to keep things clean that way, but even THAT didn't work. Why can't I simply include another perl script on Network Solutions servers!?

So answering either of the following questions would solve my problems:

1) How can I *SIMPLY* send an email on Network Solutions servers? Why does nothing work? Can I see some sample code that sends an email in under 20 or 30 lines? (This is not an unreasonable request given how easy it is to send email in perl with the right modules - I shouldn't need a 3000 line script.)

OR

2) Is there some way to use my own perl module on Network Solutions servers or to successfully use the "require" perl statement? I am surprised that neither of these things are working and feel like maybe they should be and I am missing something...

Thanks for any help in advance, would be much appreciated.
Go to the top of the page
 
+Quote Post
JakeDMG
post May 30 2012, 03:15 PM
Post #2





Group: Verified NS Member
Posts: 2
Joined: 1-December 10
Member No.: 12,001



Same issue here, sender.pm works fine on other hosting platforms but seems to choke on network solutions, it just returns fails to connect.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
Tags
No Tag inserted yet

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

RSS Lo-Fi Version    Network Solutions © 2011 Time is now: 31st October 2014 - 04:42 PM
Domain Names | Web Hosting | Web Design | Shopping Cart Software | Online Marketing | SSL Certificates